Upload process aborted after 6 minutes

Sep 9, 2010 at 9:51 PM
Edited Sep 10, 2010 at 12:56 AM

Dear Sir,

Using your "live demo" for upload a file with 40MB of size  [max file size 50MB checked] I always get an error after [6 minutes] from the server with message "NOT FOUND" and the process is aborted with a corrupted file in upload folder. The same happens with my SL4 application using Interlink engine.
Any sugestion?

Thanks

Roberto Jucá

Coordinator
Sep 10, 2010 at 10:53 AM

I have been able to repro, and am currently working to determine cause and resolution.

Coordinator
Sep 11, 2010 at 10:27 PM

OK, to confirm this is not a defect. The reason this is happening, is the temp folder is cleaned up periodically which contains the job file. The default value is 5 minutes. You need to set the value to a value larger than your antticipated longest upload.

Example below sets the purge interval to 60 minutes.

		public UploadHandler()
		{
			// Uncomment this line to turn off purging of temp files.
			//this.PurgeInterval = 0;
			this.PurgeInterval = 60; // One hour
		}
In the next release I will change the default to the maximun (660 or 11 hours). If you've downloaded the source code you can change the default as well.
Sep 11, 2010 at 11:37 PM

Dear Sir,

Thanks for your reply and for resolution too.

I just set "this.PurgeInterval = 660 [11 Hs using maximun]" in my server source code for UploadHanlder constructor and test the upload process with a 40MB file [elapsed time: 24min] and everything works fine.

Thanks again and thanks for Interlink engine.

Roberto Jucá