Firefox or Chrome browse does not work

Sep 26, 2010 at 1:24 AM
Edited Sep 26, 2010 at 1:50 AM

Dear Sir,

With your "live demo" for download a file [ex. jpg  859K] using :

  • Internet Explorer: works fine OK
  • Firefox : bad no transfer BAD
  • Chrome: bad no transfer BAD
    Some help?
Sep 26, 2010 at 5:21 AM
Edited Sep 26, 2010 at 5:22 AM

Not sure, I just tested with both Firefox and Chrome to confirm, and all works fine.

Do you have any exception logs?

To confirm, HSS Interlink has been successfully tested and ran on the following browsers:

IE: v7.0, v8.0 and v9.0 BETA
Chrome: v6.0.472.63
Firefox: v3.6.3

Silverlight: v4.0.41108.0 or Higher

Sep 26, 2010 at 1:04 PM
Edited Sep 26, 2010 at 1:06 PM

Dear Sir,

I made the approach below:

  1. A clean notebook HP with Windows 7 Professional 64Bits with IE8 and Silverlight V4.0.50826.0 no anti-virus installed
  2. Run "hssinterlink.com" from IE8 select file "Chrysanthemum.jpg 859K" and ckick "Download" button at top.
  3. Choose file name and HSS download dialog appears and download start and finish [download complete].
  4. All works fine.
  5. Now install Chrome browse V6.0.472.63
  6. Run "hssinterlink.com" from Chrome select file "Chrysanthemum.jpg 859K" and ckick "Download" button at top.
  7. Choose file name and HSS download dialog appears and STOP HERE.
  8. After few seconds Chrome shows "AW, Snap!" page with "Something went wrong..." message.
Sep 26, 2010 at 3:49 PM
Edited Sep 26, 2010 at 8:58 PM

I repeated your steps below, and confirmed I have the same issue.

 

Thanks for providing this information, I will review and follow up ASAP.

 

Sep 26, 2010 at 4:17 PM

An additional information about this issue:

For files with small size [6K] the download completes HOWEVER the file is corrupted.

Sep 26, 2010 at 4:23 PM
Edited Sep 26, 2010 at 8:58 PM

Can you try this file? AddToIpod.txt        9/25/2010 7:28:12 AM    Text Document 1KB

 

I downloaded using Google Chrome, and it worked fine.

 

So far, I think it has something to do with Google and how it handles Silverlight and download requests for JPG files.

 

Can you try downloading non JPG files and see if you have issues?

 

Sep 26, 2010 at 4:33 PM
Edited Sep 26, 2010 at 6:27 PM

EDIT: The request is sent, the file is returned, but Silverlight breaks (chrashing Google Chrome), when it tries to process the response stream, and before the GetRequestCompleted event handler is called. After lots of testing, it appears to only happen with JPG Files.

 

OK, I have confirmed it is in fact a problem with Silverlight, Google Chrome and trying to write the file to the local file system.

 

Using Fiddler I was able to confirm that the HTTP Communication between the Browser (Google Chrome) and the Web Server are successful and the file is in fact downloaded without issue. It is when it attempts to write the bytes to the file stream that the crash is happening.

 

I will continue to test…

 

Thanks again for finding and notifying me of this issue.

Sep 26, 2010 at 7:14 PM

OK, I have confirmed the following...

With Google, there appears to be some problem with using Headers and WebClient. http://forums.silverlight.net/forums/t/132768.aspx

When I remove the header, the download of JPG's works.

The purpose of the header, is to indicate the key in the appsettings that points to your File Download Handler. This is not a must have feature, but is nice in that you can have different handlers for different download scenarios. With out the header, it would always have to be a single file handler and appsetting key.

Sep 26, 2010 at 8:57 PM

Reported to Microsoft Connect. https://connect.microsoft.com/VisualStudio/feedback/details/605318/silverlight-webclient-headers-and-google-chrome

Sep 26, 2010 at 9:04 PM

Dear Sir,

Another information:

I just uploaded the file "StockTraderRI.ChartControls.zip 2K" using IE8 and hssinterlink.com.

Now using Chrome the download works BUT the file is corrupted.

So it is not only jpg extension.

Sep 26, 2010 at 9:13 PM

Thanks, this confirms the defect is Silverlight/Google Chrome with HTTP Header. I ran thru the test application (which you can download from the Microsoft Connect web site posted above) and you see that the response bytes come back random (and incorrect) with the header, and fine without the header,

Thanks again for your help in figuring this one out!

Sep 27, 2010 at 1:30 PM

A workaround... requires you to modify the DownloadFileDialog and FileDownload class files.

In the GetRequest method in the DownloadFileDialog, detect if the browser is google and if so, do not add the header.

Then on the FileDownload HTTPHandler (server side file), check for a null handler and if so, default it to 'DownloadHandler' or whatever is in your web config.

This will allow the Download process to work with Google Chrome.

As an aside, in the next release, I will change to use query strings to pass your requested FileHandler so it will no longer be an issue.

Sep 28, 2010 at 12:56 PM

Hi,

Thanks for your reply and I prefer to wait for the next release of Interlink engine.

NOTE: Remember that the same issue happens with Firefox.

Thanks again.

Roberto Jucá

Oct 2, 2010 at 10:35 PM

Latest version has been released. http://interlink.codeplex.com/releases

Issue resolved!

Oct 3, 2010 at 12:09 AM
Edited Oct 3, 2010 at 12:11 AM

Hi,

Well with version v2.1.100 everything about this issue works fine.

So after I downloaded the version v2.1.100 I changed the file DownloadHandler.cs at server to use the new property RequestedFile as you wrote at For existing users section, made some changes in my project files and did the following tests using my application with Interlink engine:

  1. Using Chrome to download and upload some files works fine NO PROBLEM
  2. Using Firefox to download and upload some files works fine NO PROBLEM
  3. This thread is now closed.

Thanks again for your assistence.

 

 

 

 

Oct 3, 2010 at 3:30 AM

Excellent, Thanks again for taking the time to test and provide confirmation.

Much appreciated!