Problem with quick start example.

Jan 4, 2011 at 3:47 PM

I am having a bit of a problem with the quick start example. I have followed the directions above, when I run the program I am prompted for files to upload, I select them and then I see the File Upload dialog box. I click upload and I get, what looks like, a windows dialog box asking me "Are you sure you want to cancel the upload in progress?" (Title is "cancel upload") . No matter whether I click OK or Cancel, I get a "Visual Studio Just in Time debugger" message that says "An unhandled exception ("unhandled Error in Silverlight Application Code: 404 Category: ManagedRunTimeError Message: System.UriFormatException: Invalid URI: The format of the URI could not be determined."

I am using SL4/VS2010 running in the debugger


Any ideas?

Coordinator
Jan 4, 2011 at 4:25 PM

I justed tested on a clean machine, and encountered the same issue. Let me review and will reply shortly.

Coordinator
Jan 4, 2011 at 5:01 PM

OK, have confirmed the defect. Thanks for posting. Work around for now, is to specify the full (absolute Url) to the FileUpload.ashx ie,

udialog.UploadUri = "http://localhost:port#/FileUpload.ashx";

Jan 4, 2011 at 6:04 PM
Edited Jan 4, 2011 at 7:22 PM

I tried changing the button_click event by adding "udialog.UploadUri = "http://localhost:port#/FileUpload.ashx";" based on one of the questions in the forum, no joy.

However, Now I am getting a different error message.  "Upload completed with errors or some files were canceled"  The Visual Studio Just in Time debugger is no longer wanting to run..  I am using the latest version of HSS Interlink.

Any more Ideas?

 

Best Regards. 


Coordinator
Jan 5, 2011 at 3:48 AM
Edited Jan 5, 2011 at 3:49 AM

Ok, I've updated the Install Package and Help File. When I modified the app to support OOB, it required an Absolute URI, and in the parsing routine where I check for absolute or relative I attempt to create a Uri from the string but forgot to specify the UriKind (AbsoluteOrRelative) in the System.Uri constructor and so it was bombing out. Anyways you should be all set. Please uninstall the current version, and install the new version and remove/add the reference to the dll's. Sorry for the defect. 

Jan 5, 2011 at 1:35 PM

I uninstalled HSS Interlink, then deleted all the HSS.Interlink.DLL & HSS.Interlink.Web.DLL files that I could find, emptied the recycle bin , installed the newest version and set the quickstart example back to to the example on the codeplex page.  No Joy.  I would be happy to schedule a Live Meeting with you if you would like to see the problem in my Environment..

 

 

Jan 6, 2011 at 4:54 PM

Thanks for the help!  The Issue has been solved by making sure that the application was configured correctly/